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IOC Editor is a free editor for Indicators of Compromise (IOCs). 10Cs are XML documents that help incident
responders capture diverse information about threats including attributes of malicious files, characteristics of registry
changes, artifacts in memory, and so on. IOC Editor provides an interface into managing data within these IOCs.

IOC Editor can:

Manipulate the logical structures that define the 10C

Apply meta-information to 10Cs including detailed descriptions or arbitrary labels
Convert I0Cs into XPath filters

Manage lists of "Terms" that are used within I0Cs

IOC Editor officially supports the following operating systems:

Windows XP
Windows 2003
Windows Vista
Windows 7

e |OC Editor requires the Microsoft .NET Framework, Version 3.5 or greater.
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Overview of IOC Editor Use

General

At a basic level, IOC Editor can be considered an editor for I0C files (.ioc extension). However, IOC Editor has
additional features that provide capability beyond just editing an I0C. IOC Editor can also be used for generating
XPath filters, and comparing two 10Cs.

Quick Start
If you are eager to begin using IOC Editor, here is a brief description of how to get started.

1. Launch the IOC Editor application and either open an empty directory or open a directory of existing IOCs. To open a
directory, select File->Open IOC Directory from the main menu bar
2. To create a new IOC, select File->New->Indicator.

File | Search  Tools Help

Mg P Indicakor Chrl+HM
[ OpenIOC Directory... Chri+O Indicator From File

= save Ctrl+s 19 window  Cirkw
2 Save Al Ctrl+shift+5

Generate Filkers 3

Exit

3. From here you can begin adding the meta information and expressions to the IOC.

a. Name, Author, and Description are pretty self-explanatory. The box on the right is for any references (see
below).

b. The Definition area is where the expressions in an IOC are added. To add an expression under the top level
OR, right-click in the Definition area and select Add Item. You will be presented with a menu of available
Indicator terms.

add Item P | r Favorites 4
el gl ' ArpEntryIbem 3
CookieHistoryItem »
DiskItem »
DnsEntryltem 3
DriverItem 3
Ernail »
EventLogltem ]
FileDownloadHiskoryItem »
FileItem »
FormHiskoryItem 3
Hiveltem 3
HookItem »
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The IOC Editor GUI consists of three main areas: a listing of all loaded 10Cs, the meta information, and the
definition.

e The left-hand listing of I0Cs allows for sorting based on the available columns (name, created date, updated date,
source, or GUID). Selecting an IOC in this list will render the contents on the right side.

e The meta information section is used to add the name, author information, description, and any references that may
provide further information or context to an IOC. The references are displayed in the top-right box. You can right-
click to add a reference. Several reference types are available, and if something different is needed, just use the
“Add Other” option.

e The definition area is where the expressions that make up the IOC are contained.

IE 10Ce 2.2.0 - Z:WWownloadsiopenioc.org_iocs

File  Search  Tools  Help

Name Created Undil  Name: (MSBET INSTALLER) Tupe  Fisfe..
[CAPPEXE 0101213124352 201 ! S
G0 METHODOLOGY) 20M10-21 161372 2013 Author: | Mandiant o :9”? F';Sla -
FIND ' NDOMWS 0001 -01-01 00:00:002 2071 gade | fisiease
SBGET [|NSTA|_|_EF|] 352011 121442 P 11 GUID: £5£3181b-955=-4f05-Eb3d-37417708eabs

HELLDCDLL [BACKDOOR) 000 -01-01 0000002 201

TURNET YIRUS (METHODOLOGY] 000-01-01 00:00:002 2013 Created: 2011-03-08 12:14:422

Feus 0001 -01-01 0000007 20011

Modified: z01z-11-05 z0:05:022

Description:

Thiz malware is the dropper executable for the odbm. dil backdoor. This particular variant dogs not uge HT TR requests when
communicating with a command/control host, and creates direct connections instead. Additionally, this inztance installs &
rootkit driver, msobj.svs. The backdoor provides attackers with the ability to upload and download files, capture keystrokes,
take screen captures, decompress and compress Microsaft Cabinet files [.cab), launch other executables, obtain an

Add: AND OR Item =

Eait ==

File Full Path contains ‘\systen3l\mstemp.Cemp

File Full Path contains Ysysten?Z)dftemp. temp

File Full Path contains Ysysten3Ziperfdi.ini

Process Handle Name is THIS3Z2NEWGAME

Process Handle Name is watcheventZ30Z1E032

Process Handle Name is iawwaitingforusS53s30

Port Remote IP iz &5 _EE_1_ZE0

Process Handle Name contains DewCtrlErnl

=l AND
Drocess MName is IEXPLORE. EXE

E-0R
Process Section Name is ciwindows\system3Z\odbm.dll
Drocess Section Name is coiwimmthsysten3Z)odbm. dll

Process Arguuments contains about:blank
= AHD
Hook Hooking Module is mscbd.sys

Loaded IOC LIStIng = Hook Hooked Function i = mation
Hook Hooked Funczicm Pﬁzjlﬂjgﬁﬂﬁé ll:

Hook Hooked Function is NtQueryDirectoryFile vl

Save

T T s
Loaded 10Cs: 7

Figure 1: |OC Editor Interface

To create an IOC, either select the File->New->Indicator menu option, right-click in the IOC Listing on the left and
select the New Indicator menu item, or use the keyboard shortcut Ctrl+N. A new item will be created with a name
of “*“New Unsaved Indicator*”, from here you can change the name, add the author, add some references, and
build the definition.
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The references can be whatever information you want to add that may help further explain the piece of malware
you are describing. The built-in options are Group, Report, Comment, Category, Grade, and Threat Group. The
final option is Other, this allows you to add whatever item you would like.

For further details on what goes in the Definition portion of an IOC, please refer to the section titled “Building an
Indicator of Compromise.”

To save an IOC, simply click on the Save button located in the bottom right of IOC Editor. This will write the IOC
to the directory that IOC Editor is currently set to.

If changes are made to an already existing IOC, they will be marked as “dirty” and highlighted yellow in the 10C
Listings on the left as shown in the following example.

File  Search  Options  Help

M ame Created Jpd.

ACELPYC [UNEMOWHN] 12/23/2009 4:41:36 PM - 1425,
AK_EXE [DBROPPE_.. 6/2372010 3:39:2... 1/72F
Firzt Logic E xample 1/258/2M71 52240 PK 1725,
HTRAN [TUNNEL... 972472009 11:44:_. 9724
Jawia [DOWMLOADER) 8A0/2010 7:29:04 P 8410,
MSEIZ [BACKDOOR)  9/24/200977:41:21 P 9724,
Second Logic Example 1/25/20171 5.26:51 P 1725,

Figure 2: "Dirty" I0C example

To save the “dirty” IOCs, you can either click on each individual highlighted I0C and then click the Save button, or
use the File->Save All menu option to do it automatically.

If you attempt to exit IOC Editor while “dirty” documents still exist, it will warn you that there are unsaved changes.

Clicking Yes will save all changes and exit, Clicking No will not save anything and then exit, and Clicking Cancel
will allow you to go back and make any further changes.

Unsaved Data Warning g
'T There are unzaved changes.
L

Do wou want to save the changes?

I es I I Mo I I Cancel

Figure 3: Unsaved changes warning
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Searching is extremely easy in IOC Editor. To search for anything found in the loaded 10Cs, select the
Search->Search for Keyword menu option. This will open a small window where you can type in the keyword you
want to look for.

Find a Keyword

findevi |

Figure 4: Search Window

Once you have typed in what you want to search for, click the Find button to begin searching. Once a hit is found,
it will be selected and the details will be displayed on the right side of IOC Editor. To continue searching for the
same keyword, select Search->Continue Last Search.

For the purposes of this guide, the following terminology will be used:
Expression: The definition of a condition, which when true, suggests that intrusion activity is present.

Simple Expression: An expression that can be defined without using “AND” or “OR” logic operators.

Complex Expression: An expression that combines multiple simple expressions using “AND” or “OR” logic operators.

Indicator of Compromise (IOC): A combination of expressions (simple, complex, or both), usually grouped together for the
purposes of describing a single piece of malware. Each IOC is given a unique ID number within the IOC EDITOR
(represented as the GUID in meta information and also is the filename of the IOC).

Indicator of Compromise

A

[
File Name: uddi32.exe 7} Simple expression
File Name: aic32ux.sys
File Name: b232ee.msi
Process Handle Name: www.UD@905.2.0rg
MDS: D42A589F58F9B45C4CAA65CC49083299

Registry Path: version

Registry Text: 5,1, 3802,0

Registry Path Contains: SOF TWARE \Microsoft\Active
Setup\Installed Components\

Registry Text: Microsoft VM Complex expression

Registry Path Contains:{6D818852-B649-B42D-
B1D1-E88ECOE37168}

File Size: 45,568
_‘.< Compile Time: 2009-05-18 07:23:37Z

Figure 5: 10C structure
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Each 10C is defined by a logic tree comprised of expressions. The logic tree starts out with a top-level “OR”
structure. When expressions are added to this structure (by right-clicking and choosing “Add Item”), an IOC will
hit as long as one of the expressions describes a true circumstance. Sometimes an I0C will be comprised of a
collection of simple expressions (MD5 hash, file name, etc.) listed in the top-level “OR” structure, with no need for
a more complex logic tree, for example:

Add: AMND OR Item -

=l OR
?"File MDE i=s AZESZ0BS3DI0ET492EF3EE722E5EC2C0F
Network DNE contains mybaddomain.net

imFile Name contains asdf.exe

Figure 6: Simple logic example

In pseudo code, the above indicator is described as follows:

(File Name is asdf.exe) ||
(File MD5 is A35930B93D3057493EF3567395BC3COF) ||
(Network DNS contains mybaddomain.net)

When required, logic branches can be built with “AND” and “OR” substructures to form complex expressions.
Each “AND” and “OR” applies to the branches in its substructure only. For example:

Add: AND OR Item =

=l OR
- File MDE is AZL330BR3DI0E57453EF3EE67335BCICAOF
- Network DNE contains mybaddomain. net
_..AI‘]D
E----File Name contains asdf.exe
- File Size contains 35343
E----File Compile Time contains Z008-03-F2T0O0:ZE4:0E52

i Bervice Name is swcoid
iwService DLL contains sweZd_log.dll

Figure 7: Logic branch example

In pseudocode, the above indicator is described as follows:

(File MD5 is A35930B93D3057493EF3567395BC3COF) ||

(Network DNS contains mybaddomain.net) ||

((File Name is asdf.exe) &&

((File Size is 35343) || (File Compile Time is 2008-09-29T00:24:052))) ||
((Service Name is svc24) && (Service DLL contains svc24_log.dll))

Note: Logically, “AND” and “OR” structures should be alternated; there is no reason to have an “OR” structure fall
directly beneath another “OR” structure, or for an “AND” structure to fall directly beneath another “AND” structure.
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To add a new item, right-click in the definition area and select “Add Item”. There are a number of different
expression categories available within IOC Editor that are determined by the contents of the Indicator Terms files
(see section titled “Indicator Terms” for further details). Some of the items available for use (“Fileltem”,
“Registryltem”, etc.) are pictured below:

Add Item 4 ¢ Favorites 4
Addliosic ' arpEntryItem 4
fddlnother CookieHiskary Tkem 3
Change Term » DiskItem 4
Change Condition 3 DnsEntryItem »
Delete DrriverIkem 4
Ernail 3
EventLoglten 3
FileDownloadHistaryItem »
FileIkem 3
FormHistoryIkem 3
Hiveltem 3
HookItem 3
Moduleltern 3
Metwiork 3
Portltem 3
PrefetchItem 3
ProcessItem 3
Reqistryltem 3
RouteEntryItem 3
Serviceltem 4
Snork 3
SwstemInfoltem 3
SystemRestareltem 3
TaskItem 3
UrlHistoryItem 3
serltem 3
wolurmeTbem 3

Figure 8: Add Item menu options

To add a File’s MD5 sum, click on Add Item—->Fileltem—-> File MD5. This will add a text box where you can type in
the MD5 sum that you would like to look for.

To add more items, continue with the right-click Add Item—>{Whatever item is needed}

Tip: If you have several of the same type to add, once you select the correct item from the “Add Item” menu and
add your information, you can just click on the “Item” button to add the same item type again.
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Add: AMD OR Item -
w

File MDE is AZERG
Network DNS conta:

File Name cont:

Figure 9: Item button

Expressions come with conditions. By default, a newly created expression will use “contains”. However, other

conditions (“is”, “is not”, “does not contain”) can be applied as needed using the “Change Condition” menu item:

add Item ¥

Add Logic »

Add Another

Change Term b

Change Condition k contains

Delete conkains not
is
is nok

Figure 10: Change Condition menu option

To add a level of logic, either click on the “AND” or the “OR” button to the left of the Definition area, or right click in
the Definition and select “Add Logic” then click on the logic item you need.

Add Ikem 3

Add Logic r AMND
add Anaother CR
Change Term 3

Change Condition 3

Delete

Figure 11: Add Logic menu option
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To provide the terms that are available for adding, IOC Editor uses indicator terms files. These files are in the
same directory as the I0C Editor executable and have an extension of .iocterms. The ones that ship with I0C
Editor are E-mail, MIR-1.3.3, MIR-1.4, and Favorites.

In order to edit existing terms or add your own, there is a terms editor built-in. To get to it, select Tools>Edit
Indicator Terms. This will bring up a window showing all terms available.

E 10C Terms Editor

Mame Description Title Path _I[:‘l:; T
» email These terms describe what might be acquirec
favari » Email 5 ubject Email/Subject string HEE
avorites =
MIB1 23 Email Sender E mail/From string W5
= Ernail Recipients Erail/Ta string WEE

MIR-1.4

Ernail O ate [Sent] Ermail/D ate date wid
Email Body Text Email/Body string W5
Ermail &ttachment Count Email/attachmentCount wair
Email &ttachment M ame Email/Attachment/M ame HEE
Email Attachment Size Email/sttachment/SizelnBytes wsle
[i' Email Attachment MIME Type | Email/attachment/tIME Type WEE
| Cieate NewFile | | 4dd Esisting File | | Delete Fie | Q| i ReceivedFombdast | Emad/Raceiveciomion I>IB

Figure 12: 10C Terms Editor

To add a new terms file, click on the “Create New File” button. This will bring up the standard dialog to save a file.
Once that is done, you can begin to add terms.

To add a term, scroll to the bottom of the list (if adding to an existing terms file), find the empty field and begin
adding your new term.

To add a term to the Favorites menu, you can either add your terms to the existing favorites term file, or add a
new one. In order to get items to populate the Favorites menu, you just need to name the terms file something
that starts with “favorites”.

Note: It is preferable to create a new favorites term file so that your terms don’t get overwritten with any future
updates to IOC Editor.
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To see what has changed between IOCs, an IOC Diff tool is available. This works best if you have two different
directories opened. To open another directory, use the File>New->Window menu option. This will open a new
IOC Editor window that can be pointed to a different directory without losing what you already have open.

To start comparing two IOCs, click on Tools=>Compare Two IOCs, this will open the I0C Diff window.

| |l |

Dirag and Drop an 10C here. Dirag and Drop an 10C here.

Figure 13: 10C Diff window

From each of the IOC Editor windows that contain the IOCs you would like to compare, simply drag and drop
each 10C onto the left or right panes. Once the second IOC has been dropped, IOC Editor will compare the
differences between the two. The changes have been color-coded, red means that the item was changed or
deleted; orange means that the item has been moved to a different layer of logic.
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[ 10c Dife = O
|ACELPYC [UNKNDWN] | ||ACELPYE [UNKNTWN) |
= oR
i~ File MDE is 4A47404FCZ1FFF4A1EC432F3CDER13590 -+ File MDE is 4A47404FCEZ1FFF4A1BC43ZFACDEZ125C
File MDS is 467EEFOS0DEESS17F0OSA45310FCFL4EE -~ File MDS is 467EEFO30DEESS17FOSA458310FCFL4EE
File MHame is acelpwc.dll
= aHD
Compile Time is Z00&6-05-07T03:41:492 E----File Compile Time i=s Z00&6-06-07T03:41:492
Size is 136704 L"File Size is 136704
= AND
Sime is 8192 é----File S8ize is 81392
Compile Time is Z00&6-05-2Z3T17:3Z:58Z amFile Compile Time i= Z006-05-F3T17:32:58Z
= AND

?uFile Name iz acelpwo.dll

Figure 14: Comparing two 10Cs

There are important items to note about creating IOCs that will be used with MIR.

1. There is currently no way to logically relate two separate objects. For example, the malware may create two separate
registry keys, with the paths REG_A and REG_B. On their own, the two registry key paths are not unique. However,
the existence of both keys in registry is significant. Unfortunately, an “AND” substructure such as the following is
invalid:

(Registryltem->Registry Path is REG_A) AND (Registryltem->Registry Path is REG_B)

MIR will interpret this logical relation as an attempt to describe the same object: a registry key with the path REG_A and
REG_B at the same time, which cannot happen.

2. Once an “AND” or “OR” substructure is created, all expressions in the logic substructure must fall within the same
category:

(Fileltem->File Name) AND (Fileltem->File Size) VALID

(Fileltem->File Name) AND (Registryltem->Registry Path) INVALID

If you need to generate the XPath filters for use in an Audit, select the File->Generate Filters menu option. You
can either generate filters for all I10Cs, or just selected ones.
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File | Search  Tools  Help
I Mew 3
|5 ©OpenlOC Directory...  CtrHo
& zave Chrl+5
@ saven) Ctr+-Shif+5
| Generate Filters 3 | al
Exit Selected

Figure 15: Generate Filters menu option
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Licensing Notices
Your use of MANDIANT IOC Editor is governed solely by the EULA, which shown below:

End-User License Agreement
IMPORTANT! PLEASE READ CAREFULLY.

THIS END-USER LICENSE AGREEMENT (THE “AGREEMENT”) IS A LEGAL AGREEMENT BETWEEN YOU
AND MANDIANT CORPORATION ("MANDIANT"). BY CLICKING "I AGREE" BELOW, YOU ACCEPT ALL
TERMS AND CONDITIONS OF THIS AGREEMENT. IF YOU DO NOT WISH TO ACCEPT THIS AGREEMENT,
YOU SHOULD CLICK "CANCEL" IN WHICH CASE YOU WILL NOT BE ABLE TO USE THE SOFTWARE.

Use

Subject to the terms and conditions of this Agreement, Mandiant hereby grants you a non-exclusive, non-
transferable license to install and use the accompanying Mandiant IOC Editor™ software (the "Software") on an
unlimited number of computers.

Reproduction and Distribution

You may copy and distribute the Software, provided that you do not modify the Software or the distribution package
(the .MSI, .ZIP or .EXE file as distributed by Mandiant) in any way or otherwise create any derivative works based
on or including the Software. You may not sell the Software or bundle it for redistribution with other software
products. You may not make or distribute copies of the Software for commercial use, whether in conjunction with
any third party software or otherwise. Any copy that you make of the Software, in whole or in part, is the property
of Mandiant. You agree to reproduce and include in their entirety all copyright, trademark and other proprietary
rights notices on any copy or any portion thereof of the materials you receive under this Agreement. You agree to
provide Mandiant with notice each time you distribute the Software, or, in the event of a widespread distribution, to
provide a single notice when you offer the Software for download or otherwise distribute the Software to more than
one recipient.

Reservation of Rights

Mandiant reserves all rights not expressly granted pursuant to this Agreement. This Agreement is not a sale of the
Software, any copies or part thereof, or any other software, and you shall have no title to or ownership in the
Software, or any copies or part thereof, regardless of the form on which the original and any copies may exist.
Mandiant reserves the right to offer upgrades to the Software, either for a fee or without cost, at Mandiant’s sole
discretion. Any such upgrades may be subject to their own End-User License Agreements, and may not be copied
and distributed except by the terms of those Agreements, if applicable.

Proprietary Rights

The Software contains valuable trade secrets of Mandiant. You agree not to decompile, disassemble, analyze, or
otherwise reverse engineer the Software. The Software is protected by United States and international copyright
laws. The names, marks, brands, logos, designs, trade dress and other designations Mandiant uses in connection
with the Software are proprietary to Mandiant. Except as stated above, this Agreement does not grant you any
intellectual property rights in the Software.

Prohibited Actions

You agree not to modify, sell, lease, or create derivative works of the Software. You agree not to use the Software
for rental or as a part of a commercial time-sharing or service bureau operation. You may not use the Software for
any illegal purpose, and you may not use the Software to access or examine any computer, or data from any
computer, that you do not have the unequivocal legal right to access or examine.

Disclaimer of Warranties
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YOU AGREE THAT THE SOFTWARE IS PROVIDED TO YOU “AS IS” AND WITHOUT ANY WARRANTIES OR
REPRESENTATIONS OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION ANY
IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR
NONINFRINGEMENT.

Indemnification

YOU AGREE TO INDEMNIFY Mandiant AND ITS DIRECTORS, OFFICERS, EMPLOYEES, AFFILIATES AND
AGENTS, AND SHALL HOLD IT HARMLESS AGAINST ANY CLAIMS, LOSSES OR DAMAGES ASSERTED BY
ANY ENTITY, WHETHER BASED ON BREACH OF CONTRACT, BREACH OF WARRANTY, TORT, PRODUCT
LIABILITY OR OTHERWISE, INCLUDING COURT COSTS AND REASONABLE ATTORNEYS’ FEES, ARISING
OUT OF OR IN CONNECTION WITH YOUR USE OF, OR ATTEMPTED USE OF, THE SOFTWARE.

Limitation of Liability

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, Mandiant SHALL NOT BE LIABLE FOR
DIRECT, INDIRECT, INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES OF ANY TYPE ARISING OUT
OF OR IN CONNECTION WITH THIS AGREEMENT OR THE SOFTWARE. MANDIANT SHALL NOT BE LIABLE
FOR ANY USE OF THE SOFTWARE, INCLUDING THE ACCESS, EXAMINATION, OR MODIFICATION OF DATA
ON ANY COMPUTER BY THE USER WITHOUT UNEQUIVOCAL LEGAL RIGHT. YOU ACKNOWLEDGE THAT
MANDIANT HAS AGREED TO MAKE THE SOFTWARE AVAILABLE IN RELIANCE ON THE EXCLUSIONS AND
LIMITATIONS OF LIABILITY AND DISCLAIMERS OF WARRANTY SET FORTH ABOVE AND THAT THE SAME
FORM AN ESSENTIAL BASIS OF THE BARGAIN BETWEEN THE PARTIES.

Export of Products

You agree that you will not, directly or indirectly, ship, transfer, transmit, export or re-export, or knowingly permit
any of the foregoing with respect to the Software, or any technical information about the Software, to any country
for which the United States Export Administration Act, any regulation thereunder, or any similar United States law
or regulation, requires an export license or other United States Government approval, unless the appropriate export
license or approval has been obtained.

Termination

You may terminate this Agreement at any time by deleting the Software. Mandiant may terminate this Agreement
at any time by providing you with individual notice, or by posting a notice on its website at Mandiant.com. When
this Agreement terminates or expires, all rights granted to you will cease, and you must immediately destroy or
purge from your computer system the Software and all copies in your possession.

Governing Law and General Provisions

The Agreement shall be governed by the laws of the Commonwealth of Virginia, excluding the application of its
conflict of law rules and the United Nations Convention on Contracts for the International Sale of Goods. Both
parties hereby submit to the exclusive jurisdiction of the Alexandria Circuit Court in Alexandria, Virginia, and the
United States District Court for the Eastern District of Virginia. If any part of any provision of this Agreement shall
be invalid or unenforceable, such part shall be deemed to be restated to reflect, as nearly as possible, the original
intentions of both of the parties in accordance with applicable law, and the remainder of the Agreement shall remain
in full force and effect. This Agreement may only be modified in a writing signed by an officer of Mandiant.
Mandiant’s failure to enforce or exercise any right or provision of this Agreement shall not constitute a waiver of
such right or provision. This Agreement is the complete and exclusive statement of the agreement between you
and Mandiant and supersedes any proposal or prior agreement, oral or written, and any other communications
between you and Mandiant relating to the subject matter of this Agreement.

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT AND UNDERSTAND IT. BY CLICKING "I
AGREE" BELOW, YOU CONSENT TO BE BOUND BY THESE TERMS AND CONDITIONS.
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